BETA

23rd March 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [23/03/18 07:25 PM] with 'Major Outage'

Issue has been resolved at [23/03/18 07:28 PM]