BETA

23rd March 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [23/03/18 05:06 PM] with 'Major Outage'

Issue has been resolved at [23/03/18 05:08 PM]