BETA

23rd March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [23/03/18 03:13 PM] with 'Major Outage'

Issue has been resolved at [23/03/18 03:16 PM]