BETA

21st March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [21/03/18 08:01 PM] with 'Major Outage'

Issue has been resolved at [21/03/18 08:04 PM]