BETA

30th March 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [30/03/17 03:50 PM] with 'Partial Outage'

Issue has been resolved at [30/03/17 05:14 PM]