BETA

17th March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [17/03/18 06:00 PM] with 'Major Outage'

Issue has been resolved at [17/03/18 06:03 PM]