BETA

16th March 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [16/03/18 10:04 PM] with 'Major Outage'

Issue has been resolved at [16/03/18 10:05 PM]