BETA

30th March 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [30/03/17 03:43 PM] with 'Partial Outage'

Issue has been resolved at [30/03/17 03:44 PM]