BETA

16th March 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [16/03/18 09:13 PM] with 'Partial Outage'

Issue has been resolved at [16/03/18 09:15 PM]