BETA

16th March 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [16/03/18 09:10 PM] with 'Major Outage'

Issue has been resolved at [16/03/18 09:11 PM]