BETA

15th March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [15/03/18 01:37 PM] with 'Major Outage'

Issue has been resolved at [15/03/18 01:49 PM]