BETA

14th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/03/19 04:33 AM] with 'Partial Outage'

Issue has been resolved at [14/03/19 04:35 AM]