BETA

12th March 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [12/03/18 07:17 PM] with 'Partial Outage'

Issue has been resolved at [12/03/18 07:19 PM]