BETA

30th March 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [30/03/17 03:03 PM] with 'Partial Outage'

Issue has been resolved at [30/03/17 03:04 PM]