BETA

12th March 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/03/18 05:07 PM] with 'Major Outage'

Issue has been resolved at [12/03/18 05:08 PM]