BETA

12th March 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/03/18 05:00 PM] with 'Partial Outage'

Issue has been resolved at [12/03/18 05:01 PM]