BETA

30th March 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [30/03/17 02:58 PM] with 'Partial Outage'

Issue has been resolved at [30/03/17 03:17 PM]