BETA

12th March 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [12/03/18 12:50 PM] with 'Major Outage'

Issue has been resolved at [12/03/18 12:52 PM]