BETA

12th March 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [12/03/18 12:20 PM] with 'Major Outage'

Issue has been resolved at [12/03/18 12:21 PM]