BETA

12th March 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [12/03/18 12:03 PM] with 'Major Outage'

Issue has been resolved at [12/03/18 12:04 PM]