BETA

12th March 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [12/03/18 10:05 AM] with 'Major Outage'

Issue has been resolved at [12/03/18 10:06 AM]