BETA

28th March 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [28/03/17 03:18 PM] with 'Partial Outage'

Issue has been resolved at [28/03/17 04:22 PM]