BETA

9th March 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [09/03/18 07:38 PM] with 'Major Outage'

Issue has been resolved at [09/03/18 07:39 PM]