BETA

9th March 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [09/03/18 07:37 PM] with 'Partial Outage'

Issue has been resolved at [09/03/18 07:38 PM]