BETA

9th March 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [09/03/18 07:14 PM] with 'Major Outage'

Issue has been resolved at [09/03/18 07:15 PM]