BETA

9th March 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [09/03/18 06:02 PM] with 'Major Outage'

Issue has been resolved at [09/03/18 06:03 PM]