BETA

8th March 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [08/03/18 02:18 PM] with 'Major Outage'

Issue has been resolved at [08/03/18 02:20 PM]