BETA

7th March 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [07/03/18 04:34 PM] with 'Major Outage'

Issue has been resolved at [07/03/18 04:36 PM]