BETA

7th March 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [07/03/18 04:24 PM] with 'Major Outage'

Issue has been resolved at [07/03/18 04:26 PM]