BETA

7th March 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [07/03/18 04:18 PM] with 'Major Outage'

Issue has been resolved at [07/03/18 04:19 PM]