BETA

7th March 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [07/03/18 04:09 PM] with 'Major Outage'

Issue has been resolved at [07/03/18 04:10 PM]