BETA

7th March 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [07/03/18 04:06 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [07/03/18 05:05 PM]