BETA

7th March 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [07/03/18 04:03 PM] with 'Partial Outage'

Issue has been resolved at [07/03/18 04:04 PM]