BETA

6th March 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [06/03/18 08:00 PM] with 'Major Outage'

Issue has been resolved at [06/03/18 08:01 PM]