BETA

6th March 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [06/03/18 07:45 PM] with 'Major Outage'

Issue has been resolved at [06/03/18 07:47 PM]