BETA

6th March 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [06/03/18 07:44 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [06/03/18 07:47 PM]