BETA

28th March 2017

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [28/03/17 07:28 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/03/17 07:37 AM]