BETA

6th March 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [06/03/18 03:37 PM] with 'Partial Outage'

Issue has been resolved at [06/03/18 03:38 PM]