BETA

6th March 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [06/03/18 03:33 PM] with 'Major Outage'

Issue has been resolved at [06/03/18 03:35 PM]