BETA

6th March 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [06/03/18 11:05 AM] with 'Partial Outage'

Issue has been resolved at [06/03/18 11:07 AM]