BETA

6th March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [06/03/18 07:09 AM] with 'Major Outage'

Issue has been resolved at [06/03/18 07:11 AM]