BETA

5th March 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [05/03/18 03:07 PM] with 'Major Outage'

Issue has been resolved at [05/03/18 03:08 PM]