BETA

4th March 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [04/03/18 12:54 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [04/03/18 10:15 PM]