BETA

4th March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [04/03/18 12:29 PM] with 'Major Outage'

Issue has been resolved at [04/03/18 12:38 PM]