BETA

4th March 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [04/03/18 10:38 AM] with 'Major Outage'

Issue has been resolved at [04/03/18 10:42 AM]