BETA

3rd March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [03/03/18 02:59 PM] with 'Major Outage'

Issue has been resolved at [03/03/18 03:04 PM]