BETA

28th March 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [28/03/17 07:27 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/03/17 07:39 AM]