BETA

3rd March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [03/03/18 08:50 AM] with 'Partial Outage'

Issue has been resolved at [03/03/18 09:02 AM]