BETA

2nd March 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [02/03/18 09:31 PM] with 'Major Outage'

Issue has been resolved at [02/03/18 10:00 PM]