BETA

2nd March 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [02/03/18 03:59 PM] with 'Partial Outage'

Issue has been resolved at [02/03/18 04:06 PM]